Shibboleth at NC State » Technical Documentation » Using Shibboleth with WordPress » Apache 2.4 ShibCompatWith24 Problem

Apache 2.4 ShibCompatWith24 Problem

Symptoms

If you follow some older notes on setting up .htaccess files for Shibboleth, you may see the suggestion that you use this directive on older Apache 2.2 servers:

ShibCompatWith24 On

If you are running on an Apache 2.4 or newer server, that directive will break the site. The Apache 2.4 version of the shibboleth module does not recognize that directive, so Apache will fail due to an unknown configuration.

Fix

The fix is simple. If you know you are running on Apache 2.4 or newer either delete or comment out that line in any of your .htaccess files. The site should start responding again as soon as the .htaccess file is saved.

To comment out a directive in .htaccess, just put a '#' character in front of the line. Like this:

# ShibCompatWith24 On

In OIT, when we migrate sites from 2.2 to 2.4, we run a script that will comment these lines out for you. Folks running on our cPanel hosting may notice those commented lines are still in the files.

If you have an .htaccess file that might run on either Apache 2.2 or 2.4, you may use this code instead. This uses Apache's mod_version to determine whether or not to use the extra directive.

<IfVersion < 2.3>
  ShibCompatWith24 On
</IfVersion>